Users Unable to Log Into Site
Incident Report for Formstack Sign
Resolved
We have applied a fix which should eliminate the login issues that users were reporting. Full functionality has been restored to Formstack Sign.
Posted Nov 21, 2020 - 17:26 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 21, 2020 - 16:58 UTC
Identified
We are seeing reports of users who are unable to log into the site. We have identified the root issue and are working towards implementing a solution.
Posted Nov 21, 2020 - 16:40 UTC
This incident affected: Main Application and Email System (SendGrid).