Users Unable to Login to Application
Incident Report for Formstack Sign
Resolved
This incident has been resolved.
Posted Nov 26, 2020 - 15:42 UTC
Monitoring
Amazon is continuing to work through the outage that has impacted Formstack Sign. While users are able to now login service delays may occur until the issue is fully resolved.

For a complete look at this outage please see Amazon's status page https://status.aws.amazon.com/.
Posted Nov 25, 2020 - 23:10 UTC
Identified
A large subset of Sign users are currently unable to login to the application or view their current documents in-app. We have tracked this issue back to the current outage with our cloud servers (AWS). Upon resolution, login functionality and access to documents should be restored completely.

Our team is actively monitoring the situation and will update this incident as we learn more.
Posted Nov 25, 2020 - 15:43 UTC
Investigating
We are currently investigating an issue that is preventing users from logging into the Sign application.
Posted Nov 25, 2020 - 14:01 UTC
This incident affected: Main Application.