Users unable to log in
Incident Report for Formstack Sign
Resolved
This incident has been resolved.
Posted Jan 25, 2021 - 20:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 25, 2021 - 17:16 UTC
Identified
We are receiving reports of some users being unable to log in. Our engineers are quickly working to resolve the issue and will update once a cause has been identified.
Posted Jan 25, 2021 - 15:47 UTC
This incident affected: Main Application.