IE login and field placement issues
Incident Report for Formstack Sign
Resolved
After extensive monitoring, we are confident that these issues are now resolved.

Thanks for your patience and understanding!
Posted May 19, 2021 - 18:27 UTC
Monitoring
We have deployed a fix and functionality for logins via Internet Explore and the drag and drop field placement are restored. We will continue monitoring for the next hour before considering this incident closed.
Posted May 19, 2021 - 15:26 UTC
Update
We have identified the cause of the issues this morning with Sign. We are working on a deployment which we are confident will address these issues. We will update you once the deployment is complete.
Posted May 19, 2021 - 14:49 UTC
Investigating
We are aware that there are some issues with Sign this morning. Specifically, logins via Internet Explorer are down. Additionally, there appears to be an issue with fields being misplaced when customers drop them into a document. We are investigating these issues and will update once we have some more information to share.
Posted May 19, 2021 - 14:45 UTC
This incident affected: Main Application and Documents.