Users Unable to Log In
Incident Report for Formstack Sign
Resolved
After considerable monitoring, the instances of login difficulties have stopped. Therefore, we are considering this issue as resolved. We apologize for any inconvenience this may have caused.
Posted Nov 30, 2020 - 22:06 UTC
Identified
The issue affecting some users' ability to log in has been identified. We are currently working on a fix and will update once said fix has been put into place.
Posted Nov 30, 2020 - 19:11 UTC
Investigating
We are receiving reports of some users being unable to log in. We are investigating the issue and will update once a cause has been identified.
Posted Nov 30, 2020 - 17:36 UTC
This incident affected: Main Application.